Unable to "import from url" (sample)

3rd day of Noodl.
Just trying to Import a sample from a URL -

It seems to get stuck displaying “Importing from URL”. (Tried it several times in the last 24hrs)
Should I be doing something to accept it"
!

Hi!
I’m actually on my way out the door now, so I don’t have time to check for myself, but I think I know the cause of your problem. I’ll come back in the evening and check if your problem is solved :slight_smile: Instead of importing while you’re in a project, try and do the import from URL when you’re at the Noodl main screen (where you see your projects - see screenshot below).

When you do the import, a new project with the example from the URL will be created - A dialog box will appear and you can give the new project any name you like. You can now try and play around with the example. If you find the example interesting and want to borrow some (or all) elements from it, you can import elements from other workspaces. To do this, go to your own project (the one you have open in the screenshot), open the node picker, and then navigate to the tab that says “Import from Project” (see screenshot below)

But yeah, we should probably work a little on the explanation on this. I totally understand why did as you did :slight_smile: But I hope this explanation helps - let me know you succeed!

Best regards, Victor from Noodl


:frowning: Thanks for trying.
That didn’t work either.
Just kept displaying “Creating new project” !
Even tried a different browser - no luck.

Maybe the next idea is to reinstall the Noodl on my computer?
James

Hmmm. Tried it on another computer… 10 minutes of waiting… just says “creating new project”.
Could someone check this page IMPORT link out please?

I’m really interested in this to see if it will work for me slight_smile:

Regards James

Yep, I’m on it. Let me get back to you when I know more.

And just to make sure, did you at any point try the following workflow:

  1. Close all open windows of Noodl, make sure no windows are still open.
  2. Reopen Noodl, and stay on the projects page. Do not enter any projects just yet.
  3. Do the import from URL, and create the new project

Let me know if you already tried this, and if not, let me know if that makes it work for you. I’ll check back on you in any case :slight_smile:

Thanks.
Yes- I Even tried it on 2 different computers
Thanks for looking into this.

Hi again James!
We had a little look at your problem. It’s a bit hard to say exactly what has gone wrong when you’ve tried importing before, especially because I tried to recreate your problem and it still worked for me.

But one thing I noticed was that the docs-link you originally provided here were from Noodl 2.5, whereas the current version of Noodl is 2.7 - are you also running Noodl 2.7 or an older version? You can check that in the top right corner of the Noodl home screen (see screenshot).

That being said, we did make some changes to the documentation because of the issue you’ve experienced (among other things your original link now refers to 2.7 and not 2.5), and there may have been other issues with some referrals before this change. Hopefully that’s also fixed now, but let’s see :slight_smile:

So once again, could I ask you to try the following?

  1. Close all open windows of Noodl, make sure no windows are still open.
  2. Reopen Noodl, and stay on the projects page. Do not enter any projects just yet. This time please also check your Noodl version - can be helpful to know if it still doesn’t work.
  3. Do the import from URL via this new link, and create the new project
  4. Report back here if this solves your problem

Hope this helps! Thanks in advance :slight_smile:
Victor

Victor,
Works like a charm :slight_smile: Thanks heaps.

PS
V 2.7.2

1 Like

Hi James.
I’m very glad to hear the problem is solved! :slight_smile: Thanks a lot for your patience, and for making us aware of the issue. Let us know if you have any other inquiries, either here or on our Discord Server. Happy Noodling!

Best regards, Victor

1 Like